error to launch egl

Topics relating to D-Day modeling/coding/skinning etc.

Moderator: Rab,d

Post Reply
User avatar
PowaBanga
Posts: 243
Joined: Wed Aug 12, 2009 5:25 am
Location: Belgium
Contact:

error to launch egl

Post by PowaBanga » Sat Apr 21, 2012 8:03 am

I try to make a few test on linux, with wine, and I have this error from egl :

Code: Select all

========= Common Initialization ========
EGL v0.3.1 by Echon
http://egl.quakedev.com/
Compiled: Mar  2 2010 @ 18:01:16
----------------------------------------

------- Filesystem Initialization ------

------------- Changing Game ------------
----------------------------------------
init time: 3ms
----------------------------------------

couldn't exec default.cfg -- not found
couldn't exec config.cfg -- not found
couldn't exec eglcfg.cfg -- not found

Winsock initialized
Hostname: Karkajou
IP Address: 192.168.1.8

-------- Refresh Initialization --------
QGL_Init: LoadLibrary ( "opengl32.dll" )
Setting video mode
Mode: 640 x 480 (windowed)
...RegisterClass succeeded
...CreateWindow succeeded
OpenGL init
...GetDC succeeded
...PFD(c32 a0 z24 s8):
...not attempting to use stereo pfd
...ChoosePixelFormat succeeded
...SetPixelFormat succeeded
...hardware acceleration detected
...qwglCreateContext succeeded
...qwglMakeCurrent succeeded
----------------------------------------
GL_PFD #15: c(32-bits) a(8-bits) z(24-bit) s(8-bit)
GL_VENDOR: Tungsten Graphics, Inc
GL_RENDERER: Mesa DRI Intel(R) Ironlake Mobile x86/MMX/SSE2
GL_VERSION: 2.1 Mesa 7.11
Renderer Class: Default
...stencil buffer available
...enabling GL_ARB_multitexture
...* using video card maximum of 8 texture units
...ignoring GL_ARB_texture_compression
...ignoring GL_EXT_texture_compression_s3tc
...ignoring GL_S3_s3tc
...enabling GL_ARB_texture_cube_map
...* Max cubemap texture size: 2048
...enabling GL_ARB_texture_env_add
...enabling GL_ARB/EXT_texture_env_combine
...GL_NV_texture_env_combine4 not found
...enabling GL_ARB_texture_env_dot3
...enabling GL_ARB_vertex_program
...enabling GL_ARB_fragment_program
...* Max texture coordinates: 8
...* Max texture image units: 16
...ignoring GL_ARB_vertex_buffer_object
...enabling GL_EXT_bgra
...enabling GL_EXT/SGI_compiled_vertex_array
...enabling GL_EXT_draw_range_elements
...* Max element vertices: 3000
...* Max element indices: 3000
...enabling GL_EXT_texture3D
...enabling GL_EXT_texture_edge_clamp
...ignoring GL_EXT_texture_filter_anisotropic
...enabling GL_SGIS_generate_mipmap
...enabling GL_EXT_stencil_two_side
...enabling GL_EXT_stencil_wrap
...WGL_EXT_swap_control not found
Using video card maximum texture size of 8192x8192
----------------------------------------

--------- Image Initialization ---------
Texture mode: GL_LINEAR_MIPMAP_NEAREST
Texture bits: default
Loading pallete table
...not found, using internal default
Creating software gamma and intensity ramps
Downloading desktop gamma ramp
...GLimp_GetGammaRamp succeeded
...using software gamma
Generating internal textures
----------------------------------------
init time: 28ms
----------------------------------------

-------- Program Initialization --------
Looking for *.vfp programs...
Looking for *.vp programs...
Looking for *.fp programs...
----------------------------------------
PROGRAMS - 0 error(s), 0 warning(s)
0 programs loaded in 2ms
----------------------------------------

-------- Shader Initialization ---------
----------------------------------------
SHADERS - 0 error(s), 0 warning(s)
6 shaders loaded in 1ms
----------------------------------------
ERROR: can't load 'default' -- not found
Cmd_RemoveCommand: called without a command pointer to remove!
name: snd_restart
Cmd_RemoveCommand: called without a command pointer to remove!
name: play
Cmd_RemoveCommand: called without a command pointer to remove!
name: stopsound
Cmd_RemoveCommand: called without a command pointer to remove!
name: soundlist
Cmd_RemoveCommand: called without a command pointer to remove!
name: soundinfo
Cmd_RemoveCommand: called without a command pointer to remove!
name: in_restart
Cmd_RemoveCommand: called without a command pointer to remove!
name: joy_advancedupdate
********************
SYS ERROR: R_CheckFont: unable to load default font!
********************
Can you help to understand this, where should be the default font ? and for this 3 file :

Code: Select all

couldn't exec default.cfg -- not found
couldn't exec config.cfg -- not found
couldn't exec eglcfg.cfg -- not found
It's not the files who are in /dday and /baseq2 ???
You can join me on IRC : in irc.quakenet.org chan : #ddayhome or on Freenode, chan #ddaynormandy .
Do not hesitate to type my pseudo to highlight me.
Or open an issue on github to highligh me by mail.
RSS

Post Reply